<!DOCTYPE html>
<html lang="en">
<head>
	<meta charset="UTF-8">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="viewport" content="width=device-width, initial-scale=1">
	<!-- This site is optimized with the Yoast SEO plugin v19.5.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08 - FlickFilosopher.com</title>
	<link rel="canonical" href="https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08 - FlickFilosopher.com" />
	<meta property="og:description" content="Survival drama Beast debuts on premium VOD; Marvel installment Thor: Love and Thunder arrives on premium VOD and Disney+; more..." />
	<meta property="og:url" content="https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html" />
	<meta property="og:site_name" content="FlickFilosopher.com" />
	<meta property="article:published_time" content="2022-09-11T21:51:34+00:00" />
	<meta property="og:image" content="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" />
	<meta name="author" content="MaryAnn Johanson" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@maryannjohanson" />
	<meta name="twitter:site" content="@maryannjohanson" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="MaryAnn Johanson" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html#article","isPartOf":{"@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html"},"author":{"name":"MaryAnn Johanson","@id":"https://www.flickfilosopher.com/#/schema/person/69c53d345555aeea1bcb21d89f647ed6"},"headline":"new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08","datePublished":"2022-09-11T21:51:34+00:00","dateModified":"2022-09-11T21:51:34+00:00","mainEntityOfPage":{"@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html"},"wordCount":364,"publisher":{"@id":"https://www.flickfilosopher.com/#organization"},"image":{"@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html#primaryimage"},"thumbnailUrl":"https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg","articleSection":["dvd/vod/streaming","imdbfeed"],"inLanguage":"en","copyrightYear":"2022","copyrightHolder":{"@id":"https://www.flickfilosopher.com/#organization"}},{"@type":"WebPage","@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html","url":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html","name":"new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08 - FlickFilosopher.com","isPartOf":{"@id":"https://www.flickfilosopher.com/#website"},"primaryImageOfPage":{"@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html#primaryimage"},"image":{"@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html#primaryimage"},"thumbnailUrl":"https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg","datePublished":"2022-09-11T21:51:34+00:00","dateModified":"2022-09-11T21:51:34+00:00","breadcrumb":{"@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html#breadcrumb"},"inLanguage":"en","potentialAction":[{"@type":"ReadAction","target":["https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html"]}]},{"@type":"ImageObject","inLanguage":"en","@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html#primaryimage","url":"https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg","contentUrl":"https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg","width":20,"height":20},{"@type":"BreadcrumbList","@id":"https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.flickfilosopher.com/"},{"@type":"ListItem","position":2,"name":"new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08"}]},{"@type":"WebSite","@id":"https://www.flickfilosopher.com/#website","url":"https://www.flickfilosopher.com/","name":"FlickFilosopher.com","description":"film criticism by maryann johanson | celebrating 25 years: 1997&ndash;2022","publisher":{"@id":"https://www.flickfilosopher.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.flickfilosopher.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en"},{"@type":"Organization","@id":"https://www.flickfilosopher.com/#organization","name":"FlickFilosopher.com","url":"https://www.flickfilosopher.com/","sameAs":["http://www.pinterest.com/maryannjohanson","https://twitter.com/maryannjohanson"],"logo":{"@type":"ImageObject","inLanguage":"en","@id":"https://www.flickfilosopher.com/#/schema/logo/image/","url":"https://www.flickfilosopher.com/wp-content/uploads/2022/03/cropped-ffBigLogo2022.png","contentUrl":"https://www.flickfilosopher.com/wp-content/uploads/2022/03/cropped-ffBigLogo2022.png","width":512,"height":512,"caption":"FlickFilosopher.com"},"image":{"@id":"https://www.flickfilosopher.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://www.flickfilosopher.com/#/schema/person/69c53d345555aeea1bcb21d89f647ed6","name":"MaryAnn Johanson","image":{"@type":"ImageObject","inLanguage":"en","@id":"https://www.flickfilosopher.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/0526ef26250e47f4acde9afffb674508?s=96&d=blank&r=g","contentUrl":"https://secure.gravatar.com/avatar/0526ef26250e47f4acde9afffb674508?s=96&d=blank&r=g","caption":"MaryAnn Johanson"},"description":"MaryAnn is your hostess here at FlickFilosopher.com...","sameAs":["https://twitter.com/maryannjohanson"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="FlickFilosopher.com &raquo; Feed" href="https://www.flickfilosopher.com/feed" />
<link rel="alternate" type="application/rss+xml" title="FlickFilosopher.com &raquo; Comments Feed" href="https://www.flickfilosopher.com/comments/feed" />
<script>
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.flickfilosopher.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.4"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='elusive-css'  href='https://www.flickfilosopher.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.flickfilosopher.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.12' media='all' />
<link rel='stylesheet' id='better-recent-comments-css'  href='https://www.flickfilosopher.com/wp-content/plugins/better-recent-comments/assets/css/better-recent-comments.min.css?ver=5.9.4' media='all' />
<link rel='stylesheet' id='bsearch-style-css'  href='https://www.flickfilosopher.com/wp-content/plugins/better-search/includes/css/bsearch-styles.min.css?ver=3.1.0' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.flickfilosopher.com/wp-includes/css/dashicons.min.css?ver=5.9.4' media='all' />
<link rel='stylesheet' id='generate-widget-areas-css'  href='https://www.flickfilosopher.com/wp-content/themes/generatepress/assets/css/components/widget-areas.min.css?ver=3.1.3' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='https://www.flickfilosopher.com/wp-content/themes/generatepress/assets/css/main.min.css?ver=3.1.3' media='all' />
<style id='generate-style-inline-css'>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</style>
<link rel='stylesheet' id='generate-secondary-nav-css'  href='https://www.flickfilosopher.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/main.min.css?ver=2.1.2' media='all' />
<style id='generate-secondary-nav-inline-css'>
.secondary-navigation{background-color:#636363;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle,.secondary-menu-bar-items .menu-bar-item > a{color:#ffffff;padding-left:16px;padding-right:16px;}.secondary-navigation .secondary-menu-bar-items{color:#ffffff;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:10px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;padding-left:16px;padding-right:16px;}.secondary-navigation .menu-item-has-children .dropdown-menu-toggle{padding-right:16px;}.secondary-navigation .main-nav ul li:not([class*="current-menu-"]):hover > a, .secondary-navigation .main-nav ul li:not([class*="current-menu-"]):focus > a, .secondary-navigation .main-nav ul li.sfHover:not([class*="current-menu-"]) > a, .secondary-menu-bar-items .menu-bar-item:hover > a{color:#ffffff;background-color:#303030;}.secondary-navigation .main-nav ul ul li:not([class*="current-menu-"]):hover > a,.secondary-navigation .main-nav ul ul li:not([class*="current-menu-"]):focus > a,.secondary-navigation .main-nav ul ul li.sfHover:not([class*="current-menu-"]) > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a{color:#222222;background-color:#ffffff;}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a{color:#ffffff;background-color:#474747;}.secondary-navigation.toggled .dropdown-menu-toggle:before{display:none;}@media (max-width: 768px) {.secondary-menu-bar-items .menu-bar-item:hover > a{background: none;color: #ffffff;}}
.secondary-navigation .main-nav ul li a, .secondary-navigation .menu-toggle, .secondary-navigation .menu-bar-items{font-weight:bold;font-size:14px;}
</style>
<link rel='stylesheet' id='generate-secondary-nav-mobile-css'  href='https://www.flickfilosopher.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/main-mobile.min.css?ver=2.1.2' media='all' />
<script src='https://www.flickfilosopher.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script src='https://www.flickfilosopher.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://www.flickfilosopher.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.flickfilosopher.com/wp-json/wp/v2/posts/103068" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.flickfilosopher.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.flickfilosopher.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.4" />
<link rel='shortlink' href='https://www.flickfilosopher.com/?p=103068' />
<link rel="alternate" type="application/json+oembed" href="https://www.flickfilosopher.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.flickfilosopher.com%2F2022%2F09%2Fnew-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.flickfilosopher.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.flickfilosopher.com%2F2022%2F09%2Fnew-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html&#038;format=xml" />
<!-- Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https://schema.org","@type":"Person","name":"MaryAnn Johanson","address":{"@type":"PostalAddress","addressLocality":"London/New York"},"email":"maryann@flickfilosopher.com","gender":"Female","birthDate":"1969.08.19","memberOf":"Online Film Critics Society, Alliance of Women Film Journalists, International Academy of Digital Arts and Sciences","nationality":"American","image":["https://www.flickfilosopher.com/wp-content/uploads/2021/08/majaug2021.jpg"],"jobTitle":"film critic, author","url":"https://www.flickfilosopher.com/","sameAs":["https://twitter.com/maryannjohanson"]}</script><!-- / Schema optimized by Schema Pro --><!-- site-navigation-element Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"on Netflix","url":"https:\/\/www.flickfilosopher.com\/on-netflix-globally"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"movies for the resistance","url":"https:\/\/www.flickfilosopher.com\/movies-for-the-resistance"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"classic film virgin","url":"https:\/\/www.flickfilosopher.com\/classic-film-virgin"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"directed by women","url":"https:\/\/www.flickfilosopher.com\/directed-by-women"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Where Are the Women? project","url":"https:\/\/www.flickfilosopher.com\/2016\/04\/where-are-the-women-rating-criteria.html"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"cinemas","url":"https:\/\/www.flickfilosopher.com\/cinemas-us-canada"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"US and Canada","url":"https:\/\/www.flickfilosopher.com\/dvd-blu-vod-us-canada"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"UK and Ireland","url":"https:\/\/www.flickfilosopher.com\/dvd-blu-vod-uk-ireland"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"dvd\/vod","url":"https:\/\/www.flickfilosopher.com\/dvd-blu-vod-us-canada"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"2022\u2019s films ranked","url":"https:\/\/www.flickfilosopher.com\/2022s-films-ranked"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"2021\u2019s films ranked","url":"https:\/\/www.flickfilosopher.com\/2021s-films-ranked"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"2020\u2019s films ranked","url":"https:\/\/www.flickfilosopher.com\/2020s-films-ranked"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"2019\u2019s films ranked","url":"https:\/\/www.flickfilosopher.com\/2019s-films-ranked"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"all recent posts","url":"https:\/\/www.flickfilosopher.com\/all-recent-posts"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"archives by month","url":"https:\/\/www.flickfilosopher.com\/archives-by-month"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"all reviews","url":"https:\/\/www.flickfilosopher.com\/all-reviews-a-m"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"A\u2013M","url":"https:\/\/www.flickfilosopher.com\/all-reviews-a-m"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"N\u2013Z","url":"https:\/\/www.flickfilosopher.com\/all-reviews-n-z"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Oscars Best Pix","url":"https:\/\/www.flickfilosopher.com\/oscar-best-picture-winners"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Oscars Best Animated Pix","url":"https:\/\/www.flickfilosopher.com\/oscar-best-animated-feature-winners"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"new comments","url":"https:\/\/www.flickfilosopher.com\/join-the-conversation"}]}</script><!-- / site-navigation-element Schema optimized by Schema Pro --><style id="generateblocks-css">.gb-container .wp-block-image img{vertical-align:middle;}.gb-container .gb-shape{position:absolute;overflow:hidden;pointer-events:none;line-height:0;}.gb-container .gb-shape svg{fill:currentColor;}.gb-container-b6c5c5e5{font-size:14px;margin:20px 20px 20px 0;border-top-style: solid;border-top-width:1px;border-bottom-style: solid;border-bottom-width:1px;border-color:#e8edf0;}.gb-container-b6c5c5e5 > .gb-inside-container{padding:15px 0;max-width:1200px;margin-left:auto;margin-right:auto;}.gb-container-b6c5c5e5.inline-post-meta-area > .gb-inside-container{display:flex;align-items:center;}.gb-icon{display:inline-flex;line-height:0;}.gb-icon svg{height:1em;width:1em;fill:currentColor;}.gb-highlight{background:none;color:unset;}div.gb-headline-a51661aa{padding-right:10px;display:inline-block;}div.gb-headline-3843ae49{padding-left:10px;border-left-style: solid;border-left-width:1px;border-color:#e8edf0;display:inline-block;}div.gb-headline-b5ba78d3{padding-left:10px;margin-left:10px;border-left-style: solid;border-left-width:1px;border-color:#e8edf0;display:inline-flex;align-items:center;}div.gb-headline-b5ba78d3 .gb-icon{padding-right:0.5em;}div.gb-headline-b5ba78d3 .gb-icon svg{width:1em;height:1em;}@media (max-width: 767px) {.gb-grid-wrapper > .gb-grid-column-b6c5c5e5{width:100%;}}</style><meta itemprop="worstRating" content="0" />

<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5">
<meta name="msapplication-TileColor" content="#ffc40d">
<meta name="theme-color" content="#ffffff">			<style id="wpsp-style-frontend"></style>
			<link rel="icon" href="https://www.flickfilosopher.com/wp-content/uploads/2022/03/cropped-ffBigLogo2022-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.flickfilosopher.com/wp-content/uploads/2022/03/cropped-ffBigLogo2022-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.flickfilosopher.com/wp-content/uploads/2022/03/cropped-ffBigLogo2022-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.flickfilosopher.com/wp-content/uploads/2022/03/cropped-ffBigLogo2022-270x270.png" />
		<style id="wp-custom-css">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</style>
		</head>

<body class="post-template-default single single-post postid-103068 single-format-standard wp-custom-logo wp-embed-responsive post-image-above-header post-image-aligned-center secondary-nav-above-header secondary-nav-aligned-left sticky-menu-fade wp-schema-pro-2.7.3 right-sidebar nav-below-header one-container nav-search-enabled header-aligned-left dropdown-hover" itemtype="https://schema.org/Blog" itemscope>
	<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>			<nav id="secondary-navigation" class="secondary-navigation grid-container" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope">
				<div class="inside-navigation grid-container grid-parent">
										<button class="menu-toggle secondary-menu-toggle">
						<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="mobile-menu">subscribe | follow</span>					</button>
					<div class="main-nav"><ul id="menu-meta-nav" class=" secondary-menu sf-menu"><li id="menu-item-96723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96723"><a target="_blank" rel="noopener" href="https://flickfilosopher.substack.com/welcome">weekly digest email</a></li>
<li id="menu-item-79804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79804"><a target="_blank" rel="noopener" href="https://www.patreon.com/maryannjohanson">join my Patreon</a></li>
<li id="menu-item-96021" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96021"><a target="_blank" rel="noopener" href="https://flickfilosopher.substack.com/about">join my Substack</a></li>
<li id="menu-item-96769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96769"><a target="_blank" rel="noopener" href="https://books2read.com/ap/x29p05/MaryAnn-Johanson">my books</a></li>
<li id="menu-item-96752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96752"><a href="https://www.flickfilosopher.com/about-2">about/contact</a></li>
<li id="menu-item-96763" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96763"><a target="_blank" rel="noopener" href="https://twitter.com/maryannjohanson"><i class="_mi elusive el-icon-twitter" aria-hidden="true" style="font-size:1.5em;"></i><span class="visuallyhidden">twitter</span></a></li>
<li id="menu-item-96767" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96767"><a target="_blank" rel="noopener" href="https://www.rottentomatoes.com/critic/maryann-johanson/movies"><img src="https://www.flickfilosopher.com/wp-content/uploads/2021/05/rotten-tomatoes-icon.svg" class="_mi _svg" aria-hidden="true" alt="" width="116000000px" height="110000000px"/><span class="visuallyhidden">rotten tomatoes</span></a></li>
<li id="menu-item-96765" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96765"><a target="_blank" rel="noopener" href="https://letterboxd.com/maryannjohanson"><img src="https://www.flickfilosopher.com/wp-content/uploads/2021/05/letterboxd-decal-l-pos-rgb.svg" class="_mi _svg" aria-hidden="true" alt="" width="500px" height="500px"/><span class="visuallyhidden">letterboxd</span></a></li>
<li id="menu-item-96768" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96768"><a target="_blank" rel="noopener" href="https://www.goodreads.com/author/show/12690.MaryAnn_Johanson"><img src="https://www.flickfilosopher.com/wp-content/uploads/2021/05/goodreads-icon.svg" class="_mi _svg" aria-hidden="true" alt="" width="512000000px" height="512000000px"/><span class="visuallyhidden">goodreads</span></a></li>
<li id="menu-item-96764" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96764"><a target="_blank" rel="noopener" href="https://www.pinterest.com/maryannjohanson/"><img src="https://www.flickfilosopher.com/wp-content/uploads/2021/05/pinterest-icon.svg" class="_mi _svg" aria-hidden="true" alt="" width="400000000px" height="400000000px"/><span class="visuallyhidden">pinterest</span></a></li>
<li id="menu-item-96766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-96766"><a target="_blank" rel="noopener" href="http://www.flickfilosopher.com/feed"><i class="_mi elusive el-icon-rss" aria-hidden="true" style="font-size:1.5em;"></i><span class="visuallyhidden">rss</span></a></li>
</ul></div>				</div><!-- .inside-navigation -->
			</nav><!-- #secondary-navigation -->
					<header class="site-header grid-container" id="masthead" aria-label="Site"  itemtype="https://schema.org/WPHeader" itemscope>
			<div class="inside-header grid-container">
				<div class="site-logo">
					<a href="https://www.flickfilosopher.com/" title="FlickFilosopher.com" rel="home">
						<img  class="header-image is-logo-image" alt="FlickFilosopher.com" src="https://www.flickfilosopher.com/wp-content/uploads/2022/03/ffLOGO2022.png" title="FlickFilosopher.com" srcset="https://www.flickfilosopher.com/wp-content/uploads/2022/03/ffLOGO2022.png 1x, https://www.flickfilosopher.com/wp-content/uploads/2022/03/ffLOGO2022.png 2x" width="1100" height="199" />
					</a>
				</div><p class="site-description">film criticism by maryann johanson | celebrating 25 years: 1997&ndash;2022</p>			</div>
		</header>
				<nav class="main-navigation grid-container has-menu-bar-items sub-menu-right" id="site-navigation" aria-label="Primary"  itemtype="https://schema.org/SiteNavigationElement" itemscope>
			<div class="inside-navigation grid-container">
				<form method="get" class="search-form navigation-search" action="https://www.flickfilosopher.com/">
					<input type="search" class="search-field" value="" name="s" title="Search" />
				</form>				<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
					<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="mobile-menu">site nav</span>				</button>
				<div id="primary-menu" class="main-nav"><ul id="menu-site-nav" class=" menu sf-menu"><li id="menu-item-79815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79815"><a href="https://www.flickfilosopher.com/on-netflix-globally">on Netflix</a></li>
<li id="menu-item-79816" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79816"><a href="https://www.flickfilosopher.com/movies-for-the-resistance">movies for the resistance</a></li>
<li id="menu-item-99186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-99186"><a href="https://www.flickfilosopher.com/classic-film-virgin">classic film virgin</a></li>
<li id="menu-item-99941" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-99941"><a href="https://www.flickfilosopher.com/directed-by-women">directed by women<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-97377" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-97377"><a href="https://www.flickfilosopher.com/2016/04/where-are-the-women-rating-criteria.html">Where Are the Women? project</a></li>
</ul>
</li>
<li id="menu-item-96762" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-96762"><a href="https://www.flickfilosopher.com/cinemas-us-canada">cinemas<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-97278" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97278"><a href="https://www.flickfilosopher.com/cinemas-us-canada">US and Canada</a></li>
	<li id="menu-item-96761" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-96761"><a href="https://www.flickfilosopher.com/cinemas-uk-ireland">UK and Ireland</a></li>
</ul>
</li>
<li id="menu-item-97280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-97280"><a href="https://www.flickfilosopher.com/dvd-blu-vod-us-canada">dvd/vod<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-61337" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61337"><a href="https://www.flickfilosopher.com/dvd-blu-vod-us-canada">US and Canada</a></li>
	<li id="menu-item-61336" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61336"><a href="https://www.flickfilosopher.com/dvd-blu-vod-uk-ireland">UK and Ireland</a></li>
</ul>
</li>
<li id="menu-item-99940" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-99940"><a href="https://www.flickfilosopher.com/2022s-films-ranked">2022’s films ranked<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-95528" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95528"><a href="https://www.flickfilosopher.com/2021s-films-ranked">2021’s films ranked</a></li>
	<li id="menu-item-97281" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97281"><a href="https://www.flickfilosopher.com/2020s-films-ranked">2020’s films ranked</a></li>
	<li id="menu-item-97282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97282"><a href="https://www.flickfilosopher.com/2019s-films-ranked">2019’s films ranked</a></li>
</ul>
</li>
<li id="menu-item-97260" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-97260"><a href="https://www.flickfilosopher.com/all-recent-posts">all recent posts<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-100024" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-100024"><a href="https://www.flickfilosopher.com/archives-by-month">archives by month</a></li>
</ul>
</li>
<li id="menu-item-65083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-65083"><a href="https://www.flickfilosopher.com/all-reviews-a-m">all reviews<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-98402" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98402"><a href="https://www.flickfilosopher.com/all-reviews-a-m">A–M</a></li>
	<li id="menu-item-98403" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98403"><a href="https://www.flickfilosopher.com/all-reviews-n-z">N–Z</a></li>
	<li id="menu-item-64746" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64746"><a href="https://www.flickfilosopher.com/oscar-best-picture-winners">Oscars Best Pix</a></li>
	<li id="menu-item-64747" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64747"><a href="https://www.flickfilosopher.com/oscar-best-animated-feature-winners">Oscars Best Animated Pix</a></li>
</ul>
</li>
<li id="menu-item-26722" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26722"><a href="https://www.flickfilosopher.com/join-the-conversation">new comments</a></li>
</ul></div><div class="menu-bar-items"><span class="menu-bar-item search-item"><a aria-label="Open Search Bar" href="#"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span></a></span></div>			</div>
		</nav>
		
	<div class="site grid-container container hfeed" id="page">
				<div class="site-content" id="content">
			
	<div class="content-area" id="primary">
		<main class="site-main" id="main">
			
<article id="post-103068" class="post-103068 post type-post status-publish format-standard hentry category-dvd-vod-streaming category-imdbfeed" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
					<header class="entry-header" aria-label="Content">
				<h1 class="entry-title" itemprop="headline">new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08</h1><div class="gb-container gb-container-b6c5c5e5 inline-post-meta-area"><div class="gb-inside-container">

<div class="gb-headline gb-headline-a51661aa gb-headline-text">by <a href="https://www.flickfilosopher.com/about-2">MaryAnn Johanson</a></div>



<div class="gb-headline gb-headline-3843ae49 gb-headline-text"><time class="entry-date published" datetime="2022-09-11T22:51:34+01:00">Sun, Sep 11, 2022</time></div>



</div></div>			</header>
			
		<div class="entry-content" itemprop="text">
			<p>A simple listing, duplicated from the <a href="https://www.flickfilosopher.com/dvd-blu-vod-us-canada">dvd/blu/vod US and Canada</a> page, of new releases and other stuff currently available, for the benefit of those playing along by RSS or keeping up via the Weekly Digest emails (<a href="https://flickfilosopher.substack.com/welcome" target="_blank" rel="noopener">sign up here</a>).</p>
<p><a href="https://www.flickfilosopher.com/dvd-blu-vod-us-canada">The most up-to-date version of this listing is always here.</a></p>
<hr />
<div class="ListingDate1">
<h2>
new from Sep 06–08<br />
</h2>
</div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/07/mrs-harris-goes-to-paris-movie-review-a-fashion-for-kindness.html">Mrs Harris Goes to Paris</a> (premium VOD/DVD)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/09/beast-2022-movie-review-he-fights-the-lion.html">Beast</a> (premium VOD)
</div>
<div class="clearboth"></div>
<div class="ListingLight">&nbsp;&nbsp;</div>
<div class="ListingTitle"><b><u><br />
I’m planning to watch&#8230;<br />
</u></b></div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/graynewsmall.jpg" alt="unlit light" title="I haven't seen it yet" border="0"></div>
<div class="ListingTitle">
Marcel the Shell with Shoes On (premium VOD)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/graynewsmall.jpg" alt="unlit light" title="I haven't seen it yet" border="0"></div>
<div class="ListingTitle">
Pinocchio (Disney+)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/graynewsmall.jpg" alt="unlit light" title="I haven't seen it yet" border="0"></div>
<div class="ListingTitle">
Thor: Love and Thunder (premium VOD/Disney+)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/graynewsmall.jpg" alt="unlit light" title="I haven't seen it yet" border="0"></div>
<div class="ListingTitle">
Where the Crawdads Sing (premium VOD)
</div>
<div class="clearboth"></div>
<p></p>
<p>(films on regular VOD and/or DVD unless otherwise noted)</p>
<p></p>
<hr />
<p>Stop endlessly scrolling Netflix, Amazon, and other VOD services! Get the <b>Weekend Watchlist</b> newsletter in your in-box every Friday with the best new films and hidden gems to stream. Only for paid <a href="https://www.patreon.com/maryannjohanson" target="_blank" rel="noopener"><b>Patreon</b></a> and <a href="https://flickfilosopher.substack.com/" target="_blank" rel="noopener"><b>Substack</b></a> subscribers.</p>
<hr />
<p></p>
<div class="ListingDate1">
<h2>
recent releases<br />
</h2>
</div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 0 -->Ali &#038; Ava
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/04/the-bad-guys-movie-review-criminally-fun.html"><!-- 6 -->The Bad Guys</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/03/the-batman-movie-review-to-bat-or-not-to-bat.html"><!-- 9 -->The Batman</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 1 -->Belfast (VOD/HBO Max)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 7 -->Benedetta
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/06/the-book-keepers-documentary-review-a-road-trip-through-love-and-sorrow.html"><!-- 7 -->The Book Keepers</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
Brian and Charles
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/03/the-burning-sea-movie-review-nightmare-fossil-fuel.html"><!-- 9 -->The Burning Sea</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 9 -->Chasing Childhood
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2021/10/cop-secret-movie-review-cold-fuzz-lff2021.html"><!-- 4 -->Cop Secret</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 3 -->Doctor Strange in the Multiverse of Madness
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 9 -->Dual
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 3 -->The Duke
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
Elvis (premium VOD/HBO Max)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 5 -->Everything Everywhere All at Once
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2020/12/farewell-amor-movie-review-family-ties-undone-and-forged-again.html"><!-- 7 -->Farewell Amor</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/07/good-luck-to-you-leo-grande-movie-review-come-as-you-are.html"><!-- 7 -->Good Luck to You, Leo Grande</a> (Hulu)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/05/happening-levenement-movie-review-the-history-about-to-repeat-itself.html"><!-- 6 -->Happening (L’événement)</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 9 -->Hatching
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/05/my-so-called-selfish-life-documentary-review-tfw-you-lack-that-certain-maternal-instinct.html"><!-- 9 -->My So-Called Selfish Life</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 1 -->Nitram
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/08/nope-movie-review-are-we-not-entertained.html"><!-- 0 -->Nope</a> (premium VOD)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/03/olga-movie-review-coming-out-swinging-for-ukraine.html"><!-- 3 -->Olga</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 9 -->Operation Mincemeat (Netflix)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/02/poly-styrene-i-am-a-cliche-documentary-review-a-howl-out-of-the-past-for-today.html"><!-- 3 -->Poly Styrene: I Am a Cliché</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 2 -->Prey (Hulu)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/08/the-princess-documentary-review-look-back-in-anger.html"><!-- 1 -->The Princess (documentary)</a> (HBO Max)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 1 -->Rogue Agent (VOD/AMC+)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 5 -->The Sea Beast (Netflix)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 8 -->Ted K
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 10 -->Turning Red (premium VOD/Disney+)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/greennewsmall.jpg" alt="green light" title="see it" border="0"></div>
<div class="ListingTitle">
<!-- 6 -->Vortex
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 3 -->Benediction
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
DC League of Super-Pets (premium VOD)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/02/dog-movie-review-magic-mutt.html"><!-- 9 -->Dog</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/04/downton-abbey-a-new-era-movie-review-should-we-improve-society-somewhat-or-nah.html"><!-- 5 -->Downton Abbey: A New Era</a> (premium VOD/DVD)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/08/eiffel-movie-review-gustaves-erection.html"><!-- 0 -->Eiffel</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 0 -->The Forgiven
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/03/gold-movie-review-dust-in-the-wind.html"><!-- 6 -->Gold</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 7 -->Infinite Storm
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 3 -->The Lost City
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 0 -->Mr Malcolm’s List
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 5 -->Mothering Sunday
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 7 -->The Northman
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/08/orphan-first-kill-movie-review-not-so-little-girl-lost.html"><!-- 0 -->Orphan: First Kill</a> (premium VOD/Paramount+)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 0 -->Radium Girls
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2021/11/shepherd-movie-review-gothic-shaggy-dog.html"><!-- 8 -->Shepherd</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 2 -->Thirteen Lives (Prime)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/05/top-gun-maverick-movie-review-were-well-into-the-danger-zone.html"><!-- 0 -->Top Gun: Maverick</a> (premium VOD)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/04/the-unbearable-weight-of-massive-talent-movie-review-cage-staged.html"><!-- 6 -->The Unbearable Weight of Massive Talent</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<!-- 9 -->Uncharted
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/yellownewsmall.jpg" alt="yellow light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/08/wild-men-vildmaend-movie-review-mild-men-more-like.html"><!-- 2 -->Wild Men (Vildmænd)</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 9 -->Aline
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/04/ambulance-movie-review-dead-on-arrival.html"><!-- 7 -->Ambulance</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 9 -->Belle (premium VOD)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/02/blacklight-movie-review-turn-it-off.html"><!-- 9 -->Blacklight</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 6 -->Fantastic Beasts: The Secrets of Dumbledore
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 4 -->The Gray Man (Netflix)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 0 -->The Immaculate Room
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2021/06/infinite-movie-review-whoa-no-paramountplus.html"><!-- 9 -->Infinite</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 0 -->Jurassic World Dominion (DVD/premium VOD)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 2 -->Lightyear (premium VOD/Disney+)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 2 -->Luck (AppleTV+)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 6 -->Memory
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<a href="https://www.flickfilosopher.com/2022/06/men-movie-review-if-it-walks-like-misogyny-and-squawks-like-misogyny.html"><!-- 1 -->Men</a>
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 10 -->Moonfall
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 6 -->Murder at Yellowstone City
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 2 -->Resurrection
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 6 -->Rubikon
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 0 -->Samaritan (Prime)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 0 -->Spin Me Round (VOD/AMC+)
</div>
<div class="clearboth"></div>
<div class="ListingLight"><img src="https://www.flickfilosopher.com/wp-content/uploads/2015/03/rednewsmall.jpg" alt="red light" border="0"></div>
<div class="ListingTitle">
<!-- 9 -->Zero Contact
</div>
<div class="clearboth"></div>
<p style="font-style: italic;">This post will be deleted at 11:59pm on Tuesday October 11th, 2022.</p>
		</div>

				<footer class="entry-meta" aria-label="Entry meta">
			<span class="cat-links"><span class="gp-icon icon-categories"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 112c0-26.51 21.49-48 48-48h110.014a48 48 0 0143.592 27.907l12.349 26.791A16 16 0 00228.486 128H464c26.51 0 48 21.49 48 48v224c0 26.51-21.49 48-48 48H48c-26.51 0-48-21.49-48-48V112z" /></svg></span><span class="screen-reader-text">Categories </span><a href="https://www.flickfilosopher.com/category/dvd-vod-streaming" rel="category tag">dvd/vod/streaming</a></span> 		</footer>
		<div class="afterreview">
<div class="ff-box"><div class="ff-shadow"><div class='ff-support'><div class="ff-box-content">
<h5>share and enjoy</h5>

<a href="https://twitter.com/intent/tweet?text=new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08&url=https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html&via=maryannjohanson&hashtags=FlickFilosopher,film" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/02/twitter-share.png"/></a>
&nbsp;
<a href="https://www.facebook.com/sharer.php?u=https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html&t=new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/02/facebook-share.png"/></a>
&nbsp;
<a href="https://www.evernote.com/clip.action?url=https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html&title=new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/02/evernote-share.png"/></a>
&nbsp;
<a href="https://pinterest.com/pin/create/bookmarklet/?media=&url=https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html&new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/02/pinterest-share.png"/></a>
&nbsp;
<a href="https://reddit.com/submit?url=https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html&title=new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/02/reddit-share.png"/></a>
&nbsp;
<a href="https://www.tumblr.com/share/link?url=https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html&name=new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/02/tumblr-share.png"/></a>
&nbsp;
<a href="mailto:?subject=new and ongoing dvd/blu/vod releases, US/Can, Sep 06–08&body=Check out this review at Flick Filosopher: https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/02/email-share.png"/></a>
&nbsp;
<a href="whatsapp://send?text=Check out this review at Flick Filosopher: https://www.flickfilosopher.com/2022/09/new-and-ongoing-dvd-blu-vod-releases-us-can-sep-06-08.html" data-action="share/whatsapp/share"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/02/whatsapp-share.png"/></a>

</div></div></div></div>
</div>	</div>
</article>
		</main>
	</div>

	<div class="widget-area sidebar is-right-sidebar" id="right-sidebar">
	<div class="inside-right-sidebar">
		<div class="simple-sidebar">
<h4>
sf/f/h flash fiction by me
</h4>

	<a href="https://books2read.com/culturalartifacts" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2021/03/CAcoverFinal.jpg" alt="Cultural Artifacts cover" width="300" height="480" /></a>
		 
<br/>

<a href="https://books2read.com/culturalartifacts" target="_blank"><b>now on Kindle Unlimited!</b></a>
	
<br/><br />

try KU for free:<br/>
	<a href="https://amzn.to/38rtL6r" target="_blank">US Amazon</a><br/>
	<a href="https://amzn.to/3kVHQ27" target="_blank">Can Amazon</a><br/>
	<a href="https://www.amazon.co.uk/kindle-dbs/hz/signup?tag=flickfilosoph-21" target="_blank">UK Amazon</a>

<br/><br />

</div>
<div class="ff-box"><div class="ff-shadow"><div class='ff-support'><div class="ff-box-content">
<h5>please help keep truly independent film criticism alive!</h5>

<a href="https://www.patreon.com/maryannjohanson" target="_blank" rel="noopener noreferrer"><img src="https://www.flickfilosopher.com/wp-content/uploads/2021/04/patreon2021small.jpg" alt="support my work at Patreon"></a>&nbsp;&nbsp;<a href="https://flickfilosopher.substack.com/about" target="_blank" rel="noopener noreferrer"><img src="https://www.flickfilosopher.com/wp-content/uploads/2021/04/substack2021small.jpg" alt="support my work at Substack"></a>
<br />
<span style="font-size: small; line-height:150%"><b>Pledge your support now at <a href="https://www.patreon.com/maryannjohanson" target="_blank" rel="noopener noreferrer">Patreon</a> or <a href="https://flickfilosopher.substack.com/about" target="_blank" rel="noopener noreferrer">Substack</a>.</b></span>
<hr />	
<a href="https://flickfilosopher.substack.com/welcome" target="_blank" rel="noopener noreferrer">Free weekly digest email at Substack.</a>
	
</div></div></div></div>
<div class="simple-sidebar">
<h4>
shop to support
</h4>

<a href="https://amzn.to/3nlS0L9" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/01/amazUS2022.jpg"></a>

<br />

<a href="https://amzn.to/335JmK8" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/01/amazCan2022.jpg"></a>
	
<br />

<a href="https://amzn.to/3Flr1FK" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2022/01/amazUK2022.jpg"></a>

<br />

<a href="https://tv.apple.com/channel/tvs.sbd.4000?at=10lIYk&amp;ct=campsign&amp;itscg=30200&amp;itsct=tv_box_badge&amp;app=tv&amp;ls=1" style="display: inline-block; overflow: hidden; border-radius: 13px; width: 250px; height: 83px;"><img src="https://tools.applemediaservices.com/api/badges/watch-on-apple-tv/badge/en-us?size=250x83&h=5a5695f35145dd40a296fdb42229a608" alt="Watch on Apple TV" style="border-radius: 13px; width: 250px; height: 83px;"></a>

<br />
<br />
	
</div><div class="ff-box"><div class="ff-shadow"><div class='ff-support'><div class="ff-box-content">

<a href="https://www.paypal.me/MaryAnnJohanson" target="_blank"><img src="https://www.flickfilosopher.com/wp-content/uploads/2021/05/PayPalMe.png" width="200" height="200" alt="PayPalMe" /></a>
		 
<br/>

<a href="https://www.paypal.me/MaryAnnJohanson" target="_blank">PayPal me...</a>

<br/>

</div></div></div></div>
<aside id="custom_html-5" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><b>FlickFilosopher.com does not accept ads, guest posts, link placements, or sponsored content.</b>
<br /><br />
<span style="font-size: small;">
As an Amazon Associate, I earn from qualifying purchases.
<br /><br />
Amazon and the Amazon logo are trademarks of Amazon.com, Inc. or its affiliates.
</span></div></aside>	</div>
</div>

	</div>
</div>


<div class="site-footer grid-container">
				<div id="footer-widgets" class="site footer-widgets">
				<div class="footer-widgets-container grid-container">
					<div class="inside-footer-widgets">
							<div class="footer-widget-1">
		<aside id="text-26" class="widget inner-padding widget_text">			<div class="textwidget"><a href="http://www.ofcs.org" target="_blank" rel="noopener"><img src="https://www.flickfilosopher.com/wp-content/uploads/2013/06/ofcsbadgesmall.gif" /></a><br />
member<br /><a href="http://www.ofcs.org" target="_blank" rel="noopener">Online Film Critics Society</a>

<br /><br />

<a href="http://www.awfj.org" target="_blank" rel="noopener"><img src="https://www.flickfilosopher.com/wp-content/uploads/2013/06/awfjbadge.gif" /></a><br />
member<br /><a href="http://www.awfj.org" target="_blank" rel="noopener">Alliance of Women Film Journalists</a>
</div>
		</aside>	</div>
		<div class="footer-widget-2">
		<aside id="text-27" class="widget inner-padding widget_text">			<div class="textwidget"><a href="https://www.rottentomatoes.com/critic/maryann-johanson/movies" target="_blank" rel="noopener"><img src="https://www.flickfilosopher.com/wp-content/uploads/2021/01/rt2021.png" /></a><br />
Tomatometer-approved critic on<br /><a href="https://www.rottentomatoes.com/critic/maryann-johanson/movies" target="_blank" rel="noopener">Rotten Tomatoes</a>

<br /><br /><br />

<a href="http://www.mrqe.com" target="_blank" rel="noopener"><img src="https://www.flickfilosopher.com/wp-content/uploads/2013/06/mrqe.gif" /></a><br />
top critic<br /><a href="http://www.mrqe.com" target="_blank" rel="noopener">Movie Review Query Engine</a>
</div>
		</aside>	</div>
		<div class="footer-widget-3">
		<aside id="custom_html-4" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><img src="https://www.flickfilosopher.com/wp-content/uploads/2014/05/amazonauthor.jpg" /><br /><a href="http://www.amazon.com/MaryAnn-Johanson/e/B00JTTRQF0/ref=ntt_athr_dp_pel_pop_1" target="_blank" rel="noopener">Amazon US author page</a><br />
<a href="http://www.amazon.co.uk/MaryAnn-Johanson/e/B00JTTRQF0/ref=ntt_athr_dp_pel_pop_1" target="_blank" rel="noopener">Amazon UK author page</a>
<br /><br />
<a href="http://www.iadas.net/" target="_blank" rel="noopener"><img src="https://www.flickfilosopher.com/wp-content/uploads/2014/09/iadas.jpg" /></a><br />
executive member<br /><a href="http://www.iadas.net/" target="_blank" rel="noopener">International Academy of Digital Arts and Sciences</a></div></aside>	</div>
						</div>
				</div>
			</div>
					<footer class="site-info" aria-label="Site"  itemtype="https://schema.org/WPFooter" itemscope>
			<div class="inside-site-info grid-container">
								<div class="copyright-bar">
					Copyright &copy; 1997–2022 MaryAnn Johanson. All rights reserved.<br /> No content appearing on this site may be reproduced, reposted, or reused in any manner without express written permission.<br /><a href="https://www.flickfilosopher.com/privacy-policy">privacy policy</a> | hosted by <a href="https://clients.fused.com/aff.php?aff=157" target="_blank"><b>Fused</b></a>				</div>
			</div>
		</footer>
		</div>

            <script>
                (function () {
                    document.addEventListener("DOMContentLoaded", function (e) {
                        if (document.hasOwnProperty("visibilityState") && document.visibilityState === "prerender") {
                            return;
                        }

                        if (navigator.webdriver || /bot|crawler|spider|crawling/i.test(navigator.userAgent)) {
                            return;
                        }

                        let referrer_url = null;

                        if (typeof document.referrer === 'string' && document.referrer.length > 0 && document.referrer.indexOf(window.location.origin) === -1) {
                            referrer_url = document.referrer;
                        }

                        const url = "https://www.flickfilosopher.com/wp-json/iawp/search"
                        const body = {
                            referrer_url,
                            ...{"payload":{"resource":"singular","singular_id":103068,"page":1},"signature":"41705eddb0c7353b7719373685fa2f24"}                        }
                        const xhr = new XMLHttpRequest()
                        xhr.open("POST", url, true)
                        xhr.setRequestHeader("Content-Type", "application/json;charset=UTF-8")
                        xhr.send(JSON.stringify(body))
                    })
                })();
            </script>
            <script id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script><!--[if lte IE 11]>
<script src='https://www.flickfilosopher.com/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.1.3' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script src='https://www.flickfilosopher.com/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.1.3' id='generate-menu-js'></script>
<script id='generate-navigation-search-js-extra'>
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
</script>
<script src='https://www.flickfilosopher.com/wp-content/themes/generatepress/assets/js/navigation-search.min.js?ver=3.1.3' id='generate-navigation-search-js'></script>
			<script type="text/javascript" id="wpsp-script-frontend"></script>
			
</body>
</html>
